Sploder RPG

By alonessix :: Saturday March 9th, 2013

 

This game requires the Adobe Flash Player.

Enable Flash

make a game

If anyone likes the idea, I'll add more levels and have the classes be useful. *WARNING* |THIS IS A DEMO VERSION!!!|

 

More games by alonessix