Attention Sploder Users...

By elroysice :: Thursday July 1st, 2010

 

This game requires the Adobe Flash Player.

Enable Flash

make a game

I have been an editor for a few months now. Yes, you an probably see where this is going. Remember, do NOT ask someone to feature your game unless you are requesting in a Featuring Thread in the Forums. If you do ask any editor to feature a game, we will NOT feature that game. If you repeatedly do this, then we (or at least I) will not feature any games by you. Thank you. ~E~

 

Tags: sorry


More games by elroysice