Metroid Engine Test

By omega :: Saturday July 30th, 2011

 

This game requires the Adobe Flash Player.

Enable Flash

make a game

As I finish a feature, it will be put in this game for you to test. As of now, the engine is in version 4.

 

Tags: engine


More games by omega