I am an idiot.

By spare101 :: Saturday September 5th, 2009

 

This game requires the Adobe Flash Player.

Enable Flash

make a game

I must die!

 

More games by spare101