April Fools Maze

By supersamp :: Sunday August 2nd, 2009

 

This game requires the Adobe Flash Player.

Enable Flash

make a game

This is ALOT harder than it seems. It can be done though.

 

More games by supersamp