Dont Hug Me Im Scared is for ADULTS

By gabrieletheman :: Friday July 22nd, 2016

This game requires the Adobe Flash Player.

Enable Flash

make a game

The show looks just like a show for kids, but it is not really for kids! (The minimum of the age for watch it must be 18 ).


More games by gabrieletheman