Copyable player selector NO JOKE

By mirandajennifer6 :: Tuesday August 26th, 2014

This game requires the Adobe Flash Player.

Enable Flash

make a game

VERSION 0.2, now it has an background and one glitch was removed! Now it will be funniest select what player do you will use!

 

More games by mirandajennifer6