Plat 2.0

By pizzaman1 :: Sunday October 17th, 2010

This game requires the Adobe Flash Player.

Enable Flash

make a game

Yup, this game was made in less than a day. This is just a short game testing various new platformer additions. Also, I haven't made a plat in a long time.

 

More games by pizzaman1